[PATCH] D139779: [Support] Add transformOptional

David Blaikie via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sat Dec 10 16:11:51 PST 2022


dblaikie added a comment.

Could we call it `transform`, or does that complicate things with overload resolution/other functions named `transform`?



================
Comment at: llvm/unittests/ADT/STLForwardCompatTest.cpp:49-78
+struct MoveOnly {
+  static unsigned MoveConstructions;
+  static unsigned Destructions;
+  static unsigned MoveAssignments;
+  int val;
+  explicit MoveOnly(int val) : val(val) {
+  }
----------------
Do we have enough of these for various unit tests we could have a common/shared one?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D139779/new/

https://reviews.llvm.org/D139779



More information about the llvm-commits mailing list