[PATCH] D115707: [NFC][regalloc] Introduce the RegAllocEvictionAdvisorAnalysis

Wenlei He via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 16 09:13:50 PST 2021


wenlei added inline comments.


================
Comment at: llvm/lib/CodeGen/RegAllocEvictionAdvisor.cpp:113-115
+      EnableLocalReassign(EnableLocalReassignment ||
+                          MF.getSubtarget().enableRALocalReassignment(
+                              MF.getTarget().getOptLevel())) {}
----------------
mtrofin wrote:
> wenlei wrote:
> > mtrofin wrote:
> > > wenlei wrote:
> > > > nit: move this piece below into a helper for use in both advisor and RAGreedy.
> > > > 
> > > > ```
> > > > EnableLocalReassignment ||
> > > >                           MF.getSubtarget().enableRALocalReassignment(
> > > >                               MF.getTarget().getOptLevel())
> > > > ```
> > > > 
> > > > This also reminds me of the advisor layer issue discussed in the previous patch. The advisor is tied to greedy. Would be good to address that soon.
> > > I could frontend that, but I'm not sure it would help in this case: we don't appear to be using this field anywhere else in RAGreedy, it's only used by the methods that would move with the default advisor. (Maybe I'm missing something though?)
> > Took another look, you're right. sorry for the confusion.
> Ack. So we can then leave the flag definition here, too, correct?
Sounds good.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D115707/new/

https://reviews.llvm.org/D115707



More information about the llvm-commits mailing list