[PATCH] D95998: [Debug-Info] [NFC] use emitDwarfUnitLength to handle debug line section unit length field

Igor Kudrin via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Feb 22 02:39:13 PST 2021


ikudrin accepted this revision.
ikudrin added a comment.

Looks good, thanks!



================
Comment at: llvm/lib/MC/MCDwarf.cpp:492
 
+  MCSymbol *SymWithoutUnitLength = context.createTempSymbol("debug_line_");
+
----------------
Don't think a prefix for this temporary symbol is needed. Even `ProEndSym`, which is emitted much farther from the expression, does not have it.

And maybe rename it to something like `ProStartSym` to match the other one?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D95998/new/

https://reviews.llvm.org/D95998



More information about the llvm-commits mailing list