[PATCH] D84683: [VPlan] Use VPValue def for VPWidenGEPRecipe.

Dave Green via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 28 14:18:27 PDT 2020


dmgreen added inline comments.


================
Comment at: llvm/lib/Transforms/Vectorize/VPlan.h:907
+
+  GetElementPtrInst *getUnderlyingInstruction() {
+    return cast<GetElementPtrInst>(getUnderlyingValue());
----------------
Should this be called getUnderlyingGEP? Or should they standardize on getUnderlyingInstruction? If so I might recommend getUnderlyingInstr at least to cut down the lengths of the lines, without losing much by way of readability.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D84683/new/

https://reviews.llvm.org/D84683



More information about the llvm-commits mailing list