[PATCH] D87916: [PowerPC][LLD] Extend R2 save stub to support offsets of more than 26 bits

Sean Fertile via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Sep 24 06:39:24 PDT 2020


sfertile accepted this revision as: sfertile.
sfertile added a comment.

2 minor comments but otherwise LGTM.



================
Comment at: lld/ELF/Thunks.cpp:933
+    in.ppc64LongBranchTarget->addEntry(&destination, addend);
+    const int64_t TOCoffset =
+        in.ppc64LongBranchTarget->getEntryVA(&destination, addend) -
----------------
Can we change the name to avoid the clang tidy warnings?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D87916/new/

https://reviews.llvm.org/D87916



More information about the llvm-commits mailing list