[PATCH] D87294: [IRSim][IROutliner] Adding support for elevating constants that are not the same in each region to arguments

Jon Roelofs via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Sep 15 10:24:50 PDT 2020


jroelofs added inline comments.


================
Comment at: llvm/lib/Transforms/IPO/IROutliner.cpp:318
+                          std::vector<unsigned> &Inputs) {
+  DenseSet<unsigned> InInput;
+  // Iterate over the instructions, and find what constants will need to be
----------------
s/Seen/InInput/

might be a better name?


================
Comment at: llvm/lib/Transforms/IPO/IROutliner.cpp:596
+  // Remove the old instruction.
+  OldCall->eraseFromParent();
+  Region.Call = Call;
----------------
I'd expect an RAUW... what if the call returns something?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D87294/new/

https://reviews.llvm.org/D87294



More information about the llvm-commits mailing list