[llvm] aa8be5a - [Scalarizer] Avoid changing name of non-instructions

Bjorn Pettersson via llvm-commits llvm-commits at lists.llvm.org
Tue Sep 15 05:16:42 PDT 2020


Author: Bjorn Pettersson
Date: 2020-09-15T14:15:50+02:00
New Revision: aa8be5aeead7ad894270aa025e7165169c1a54d2

URL: https://github.com/llvm/llvm-project/commit/aa8be5aeead7ad894270aa025e7165169c1a54d2
DIFF: https://github.com/llvm/llvm-project/commit/aa8be5aeead7ad894270aa025e7165169c1a54d2.diff

LOG: [Scalarizer] Avoid changing name of non-instructions

The "takeName" logic in ScalarizerVisitor::gather did not consider
that the value vector could refer to non-instructions, such as
global variables. This patch make sure that we avoid changing the
name of a value if it isn't an instruction.

Reviewed By: lebedev.ri

Differential Revision: https://reviews.llvm.org/D87685

Added: 
    llvm/test/Transforms/Scalarizer/global-bug-2.ll

Modified: 
    llvm/lib/Transforms/Scalar/Scalarizer.cpp

Removed: 
    


################################################################################
diff  --git a/llvm/lib/Transforms/Scalar/Scalarizer.cpp b/llvm/lib/Transforms/Scalar/Scalarizer.cpp
index 3bc0cbde8c19..c7fe21f2a3da 100644
--- a/llvm/lib/Transforms/Scalar/Scalarizer.cpp
+++ b/llvm/lib/Transforms/Scalar/Scalarizer.cpp
@@ -398,7 +398,8 @@ void ScalarizerVisitor::gather(Instruction *Op, const ValueVector &CV) {
         continue;
 
       Instruction *Old = cast<Instruction>(V);
-      CV[I]->takeName(Old);
+      if (isa<Instruction>(CV[I]))
+        CV[I]->takeName(Old);
       Old->replaceAllUsesWith(CV[I]);
       PotentiallyDeadInstrs.emplace_back(Old);
     }

diff  --git a/llvm/test/Transforms/Scalarizer/global-bug-2.ll b/llvm/test/Transforms/Scalarizer/global-bug-2.ll
new file mode 100644
index 000000000000..60f61ab08184
--- /dev/null
+++ b/llvm/test/Transforms/Scalarizer/global-bug-2.ll
@@ -0,0 +1,20 @@
+; RUN: opt < %s -scalarizer -S -o - | FileCheck %s
+; RUN: opt < %s -passes='function(scalarizer)' -S | FileCheck %s
+
+; The scalarizer used to change the name of the global variable
+; Check that the we don't do that any longer.
+;
+; CHECK: @c.a = global i16 0, align 1
+
+ at c.a = global i16 0, align 1
+
+define void @c() {
+entry:
+  br label %for.cond1
+
+for.cond1:                                        ; preds = %for.cond1, %entry
+  %d.sroa.0.0 = phi <4 x i16*> [ <i16* @c.a, i16* @c.a, i16* @c.a, i16* @c.a>, %entry ], [ %d.sroa.0.1.vec.insert, %for.cond1 ]
+  %d.sroa.0.0.vec.extract = extractelement <4 x i16*> %d.sroa.0.0, i32 0
+  %d.sroa.0.1.vec.insert = shufflevector <4 x i16*> <i16* @c.a, i16* null, i16* undef, i16* undef>, <4 x i16*> %d.sroa.0.0, <4 x i32> <i32 0, i32 1, i32 6, i32 7>
+  br label %for.cond1
+}


        


More information about the llvm-commits mailing list