[PATCH] D85794: [WIP][llvm][LV] Replace `unsigned VF` with `ElementCount VF` [NFCI]

Roger Ferrer Ibanez via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Aug 12 13:11:33 PDT 2020


rogfer01 added a comment.

> I have applied all feedback, but I have proposed an alternative approach to the one suggested by @rengolin in one of the comments, for static methods like `ElementCount::get[Non]Scalable`.

If the suggested methods will become unused once we start iterating over the scalable component, then perhaps we can live with those `{VF, false}` things. Calling the constructor makes more explicit what is being constructed so I think it is better than just the initializer-list (at expense of some extra verbosity).

`ElementCount::getDisabled` does not seem ideal as it is unclear what a "disabled" `ElementCount` means. `ElementCount::getZero` looks to me slightly better as long we stay within the domain of "counting things".


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D85794/new/

https://reviews.llvm.org/D85794



More information about the llvm-commits mailing list