[PATCH] D81585: [AIX][XCOFF][Patch1] Provide decoding trace back table information API for xcoff object file for llvm-objdump -d

Hubert Tong via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jul 20 07:10:10 PDT 2020


hubert.reinterpretcast added inline comments.


================
Comment at: llvm/lib/Object/XCOFFObjectFile.cpp:933
+
+uint8_t XCOFFTracebackTable::getVersion() const {
+  return GETBITWITHMASKSHIFT(0, VersionMask, VersionShift);
----------------
DiggerLin wrote:
> hubert.reinterpretcast wrote:
> > I am not sure that functions that perform a read via a pointer to non-owned memory should be named "get" functions as opposed to "read" functions.
> I think maybe better to keep name "get" functions . 
> if the function has argument as 
> getVersion(void* prt, uint64_t size), it maybe better to change to readVersion(void* prt, uint64_t size).
> 
> but there is no argument here, keep getVersion myabe better.
Another possibility for the name is "extract". @DiggerLin, please see if @jhenderson has an opinion on this naming aspect.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D81585/new/

https://reviews.llvm.org/D81585





More information about the llvm-commits mailing list