[PATCH] D83885: [Propeller]: Use a descriptive temporary symbol name for the end of the basic block.

Rahman Lavaee via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jul 15 09:20:30 PDT 2020


rahmanl created this revision.
rahmanl added a reviewer: tmsriram.
rahmanl added a project: LLVM.
Herald added subscribers: llvm-commits, hiraditya.

This patch changes the functionality of AsmPrinter to name the basic block end labels as LBB_END${i}_${j}, with ${i} being the identifier for the function and ${j} being the identifier for the basic block. This improves the readability of assembly generated for Propeller, both with //labels// and //sections//. It also allows the end label to be cached just like the symbol for the basic block.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D83885

Files:
  llvm/include/llvm/CodeGen/MachineBasicBlock.h
  llvm/lib/CodeGen/AsmPrinter/AsmPrinter.cpp
  llvm/lib/CodeGen/MachineBasicBlock.cpp
  llvm/test/CodeGen/X86/basicblock-sections-clusters.ll
  llvm/test/CodeGen/X86/basicblock-sections-listbb.ll
  llvm/test/CodeGen/X86/basicblock-sections.ll
  llvm/test/DebugInfo/X86/basicblock-sections_1.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D83885.278215.patch
Type: text/x-patch
Size: 10374 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200715/d2da0d9a/attachment.bin>


More information about the llvm-commits mailing list