[PATCH] D79962: Fix the verification of DIEs with DW_AT_ranges.

Xing GUO via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jun 17 19:58:50 PDT 2020


Higuoxing added inline comments.


================
Comment at: llvm/include/llvm/DebugInfo/DWARF/DWARFVerifier.h:64
+    /// This is used for finding overlapping ranges in the DW_AT_ranges
+    /// attribute if a DIE. It is also used as a set of address ranges that
+    /// children address ranges must all be contained in.
----------------
"if a DIE" -> "of a DIE" ?


================
Comment at: llvm/lib/DebugInfo/DWARF/DWARFVerifier.cpp:402
   if (!IsObjectFile || IsMachOObject || Die.getTag() != DW_TAG_compile_unit) {
+    bool GotError = false;
     for (auto Range : Ranges) {
----------------
I think the variable name `GotError` is a little bit ambiguous here. What about renaming it to `InvalidOrOverlapped` or something else?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D79962/new/

https://reviews.llvm.org/D79962





More information about the llvm-commits mailing list