[PATCH] D80857: [lld-macho] Handle GOT relocations of non-dylib symbols

Jez Ng via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sat Jun 13 23:58:01 PDT 2020


int3 marked 2 inline comments as done.
int3 added inline comments.


================
Comment at: lld/test/MachO/local-got.s:1
+# REQUIRES: x86
+# RUN: llvm-mc -filetype=obj -triple=x86_64-apple-darwin %s -o %t.o
----------------
smeenai wrote:
> int3 wrote:
> > MaskRay wrote:
> > > `test/ELF/local-got.s` may not be the best name
> > > 
> > > If you can think of a better name, use that.
> > I'm fine with the current name...
> How about got-reloc-for-local-symbol?
heh, I prefer local-got over got-reloc-for-local-symbol, it's much terser :p  


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D80857/new/

https://reviews.llvm.org/D80857





More information about the llvm-commits mailing list