[PATCH] D80333: [mlir] NFC - Add a builder to vector.transpose

Aart Bik via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed May 20 17:08:01 PDT 2020


aartbik accepted this revision.
aartbik added inline comments.
This revision is now accepted and ready to land.


================
Comment at: mlir/include/mlir/Dialect/Vector/VectorOps.td:1382
+    "OpBuilder &builder, OperationState &result, Value vector, "
+    "ArrayRef<int64_t> permutation">];
   let extraClassDeclaration = [{
----------------
nit: transp is current name (that may not be a very good one, but let's stay consistent)


================
Comment at: mlir/include/mlir/EDSC/Builders.h:361
 
+  /// Return the base memref.
   Value getBase() const { return value; }
----------------
Nit: here and below

others use Emits and Returns, so let's use the "s" form of verb in this and comments below


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D80333/new/

https://reviews.llvm.org/D80333





More information about the llvm-commits mailing list