[PATCH] D80029: Fix quadratic LexicalScopes::constructScopeNest(...), NFC

David Blaikie via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon May 18 14:06:09 PDT 2020


dblaikie accepted this revision.
dblaikie added a comment.
This revision is now accepted and ready to land.

Looks good - once the variable names are fixed up to match LLVM conventions. Thanks!



================
Comment at: llvm/lib/CodeGen/LexicalScopes.cpp:239
   while (!WorkStack.empty()) {
-    LexicalScope *WS = WorkStack.back();
+    auto &p = WorkStack.back();
+    LexicalScope *WS = p.first;
----------------
Please fix/ensure the names of variables conform with the LLVM naming conventions (Upper case-starting camelcase)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D80029/new/

https://reviews.llvm.org/D80029





More information about the llvm-commits mailing list