[PATCH] D79717: [MLIR] Add shape.witness type and ops

Theodore Popp via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri May 15 02:19:25 PDT 2020


tpopp marked an inline comment as done.
tpopp added inline comments.


================
Comment at: mlir/test/Dialect/Shape/ops.mlir:73
+  %w3 = "shape.all"(%w0, %w1) : (!shape.witness, !shape.witness) -> !shape.witness
+  "shape.assert_and_exec"(%w3) ( {
+    "shape.assert_and_exec_yield"(%2) : (!shape.shape) -> ()
----------------
herhut wrote:
> This needs updating to the new name for the region. Looking at the example,  `assuming_region` conveys the intent of the op much better. We could even drop the `region` so that it reads (with some potential later custom assembly form)
> 
> ```
> %res = shape.assuming %w3 do {
> } : !shape.shape
> ```
> 
Done. `assuming_all` is a bad name I think then (I would expect it to be a multiple input form of `assuming`). I will revisit that later though.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D79717/new/

https://reviews.llvm.org/D79717





More information about the llvm-commits mailing list