[PATCH] D76305: [RS4GC] Fix algorithm to avoid setting vector BDV for scalar derived pointer

Anna Thomas via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu May 14 06:25:40 PDT 2020


anna marked 3 inline comments as done.
anna added inline comments.


================
Comment at: llvm/lib/Transforms/Scalar/RewriteStatepointsForGC.cpp:667
+// Returns true if First and Second values are both scalar or both vector.
+static bool isCorrectType(Value *First, Value *Second) {
+  return isa<VectorType>(First->getType()) ==
----------------
skatkov wrote:
> skatkov wrote:
> > Confusing name...
> > areTypesMatched? or something like this?
> May be even more specific - areBothVectorOrScalar?
changed name to `areBothVectorOrScalar`.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D76305/new/

https://reviews.llvm.org/D76305





More information about the llvm-commits mailing list