[PATCH] D79867: [VectorUtils] Expose vector-function-abi-variant mangling as a utility. NFC

Simon Moll via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu May 14 03:10:18 PDT 2020


simoll added a comment.

Make sense to expose this API. Seems ok for me conceptually.
+1 for a test and a nit.



================
Comment at: llvm/include/llvm/Analysis/VectorUtils.h:184
+/// <vectorname> = the name of the vector function.
+std::string mangleVectorName(StringRef VectorName, StringRef ScalarName,
+                             unsigned numArgs, unsigned VF);
----------------
Since this is for the LLVM-specific VectorABI, why not rename it to `mangleLLVMVectorName` for less potential confusion?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D79867/new/

https://reviews.llvm.org/D79867





More information about the llvm-commits mailing list