[PATCH] D79658: [mlir][Affine] Introduce affine.vector_load and affine.vector_store

Diego Caballero via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed May 13 16:57:16 PDT 2020


dcaballe updated this revision to Diff 263888.
dcaballe marked 9 inline comments as done.
dcaballe added a comment.
Herald added a subscriber: jurahul.

Addressing feedback.

- Added specific verifiers for affine.vector_load and affine.vector_store.
- Refactored affine.load and affine.store verifiers to avoid code duplication.
- Added invalid tests.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D79658/new/

https://reviews.llvm.org/D79658

Files:
  mlir/include/mlir/Conversion/AffineToStandard/AffineToStandard.h
  mlir/include/mlir/Dialect/Affine/IR/AffineOps.td
  mlir/include/mlir/Dialect/Vector/VectorOps.td
  mlir/lib/Conversion/AffineToStandard/AffineToStandard.cpp
  mlir/lib/Dialect/Affine/IR/AffineOps.cpp
  mlir/lib/Dialect/Vector/VectorOps.cpp
  mlir/test/Conversion/AffineToStandard/lower-affine-to-vector.mlir
  mlir/test/Dialect/Affine/invalid.mlir
  mlir/test/Dialect/Affine/load-store.mlir

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D79658.263888.patch
Type: text/x-patch
Size: 33581 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200513/6bdc6d67/attachment.bin>


More information about the llvm-commits mailing list