[PATCH] D79717: [MLIR] Add shape.witness type and ops

Stephan Herhut via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed May 13 03:43:49 PDT 2020


herhut added a comment.

Great start. Good to go with comments addressed.



================
Comment at: mlir/lib/Dialect/Shape/IR/Shape.cpp:291
 
+//===----------------------------------------------------------------------===//
+// AnyOp
----------------
Please keep these sorted.


================
Comment at: mlir/test/Dialect/Shape/ops.mlir:73
+  %w3 = "shape.all"(%w0, %w1) : (!shape.witness, !shape.witness) -> !shape.witness
+  "shape.assert_and_exec"(%w3) ( {
+    "shape.assert_and_exec_yield"(%2) : (!shape.shape) -> ()
----------------
This needs updating to the new name for the region. Looking at the example,  `assuming_region` conveys the intent of the op much better. We could even drop the `region` so that it reads (with some potential later custom assembly form)

```
%res = shape.assuming %w3 do {
} : !shape.shape
```



Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D79717/new/

https://reviews.llvm.org/D79717





More information about the llvm-commits mailing list