[PATCH] D78106: [CSInfo][NFC] Interpret loaded parameter value separately

Nikola Tesic via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon May 4 07:59:59 PDT 2020


ntesic marked 2 inline comments as done.
ntesic added inline comments.


================
Comment at: llvm/lib/CodeGen/AsmPrinter/DwarfDebug.cpp:643
+/// Interpret the value loaded into register by \p CurMI.
+static void interpretValue(const MachineInstr *CurMI,
+                           FwdRegWorklist &ForwardedRegWorklist,
----------------
dstenb wrote:
> As an instruction may produce multiple register values, maybe this should be called `interpretValues`, and the comment above updated to reflect that?
Yes, It makes more sense. Thanks.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D78106/new/

https://reviews.llvm.org/D78106





More information about the llvm-commits mailing list