[PATCH] D78520: [InlineSpiller] simplify insertReload() NFC

Eli Friedman via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Apr 20 16:18:19 PDT 2020


efriedma accepted this revision.
efriedma added a comment.
This revision is now accepted and ready to land.

LGTM with one minor comment.



================
Comment at: llvm/lib/CodeGen/InlineSpiller.cpp:934
 /// not relevant.
-static bool isFullUndefDef(const MachineInstr &Def) {
+static bool isRealSpill(const MachineInstr &Def) {
   if (!Def.isImplicitDef())
----------------
Not sure renaming this helper is really useful; the old name is the property it's actually computing, which makes more sense than naming it after what you plan to do with the result.

Not a big deal either way.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D78520/new/

https://reviews.llvm.org/D78520





More information about the llvm-commits mailing list