[PATCH] D77881: [VectorUtils] add IR-level analysis for widening of shuffle mask

Sanjay Patel via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sat Apr 11 10:39:47 PDT 2020


spatel updated this revision to Diff 256782.
spatel added a comment.

Patch updated:

1. Rebased after rG1318ddbc14c2 <https://reviews.llvm.org/rG1318ddbc14c28eee63df9cfe3ed92dca82557935> (name change for scaleShuffleMask), so this patch doesn't alter comments in the other function.
2. Adopted most of the implementation suggestions to improve readability/iteration processing . I couldn't take the 5-line 'for' statement, so used a take_front/drop_front pattern instead. Also used a straight 'for' loop to avoid adding an #include for llvm::seq(). Hopefully, that's same or better readability.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D77881/new/

https://reviews.llvm.org/D77881

Files:
  llvm/include/llvm/Analysis/VectorUtils.h
  llvm/lib/Analysis/VectorUtils.cpp
  llvm/unittests/Analysis/VectorUtilsTest.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D77881.256782.patch
Type: text/x-patch
Size: 6408 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200411/5298ba00/attachment.bin>


More information about the llvm-commits mailing list