[PATCH] D77768: [mlir][NFC] Refactor ClassID into a TypeID class.

River Riddle via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 8 22:07:38 PDT 2020


rriddle added inline comments.


================
Comment at: mlir/lib/Dialect/Affine/Transforms/AffineLoopInvariantCodeMotion.cpp:44-45
 ///       uses.
-struct LoopInvariantCodeMotion
-    : public AffineLoopInvariantCodeMotionBase<LoopInvariantCodeMotion> {
+struct AffineLoopInvariantCodeMotion
+    : public AffineLoopInvariantCodeMotionBase<AffineLoopInvariantCodeMotion> {
   void runOnFunction() override;
----------------
mehdi_amini wrote:
> rriddle wrote:
> > stephenneuendorffer wrote:
> > > rename seems unrelated?
> > It's actually not, as the name of this pass matches the one for the other LICM. 
> That has me concerned with the mechanism here if it can't differentiate.
I discovered a magic incantation to get things to link properly across DLLs, but it requires a combo of dllexport/dllimport which LLVM doesn't even use now. We can punt until linking across DLLs becomes a problem. In the meantime this refactoring is still valuable.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D77768/new/

https://reviews.llvm.org/D77768





More information about the llvm-commits mailing list