[PATCH] D77676: [mlir][Linalg] Use subview instead of linalg.slice in Promotion.cpp

Ahmed S. Taei via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Apr 7 16:22:49 PDT 2020


asaadaldien accepted this revision.
asaadaldien added inline comments.
This revision is now accepted and ready to land.


================
Comment at: mlir/lib/Dialect/Linalg/Transforms/Promotion.cpp:57
+    return size;
+  int64_t minConst = std::numeric_limits<int64_t>::max();
+  for (auto e : affineMinOp.getAffineMap().getResults())
----------------
What about `return size` here `if (!llvm::any_of(affineMinOp.getAffineMap().getResults())` is a an `AffineConstantExpr` ?


================
Comment at: mlir/lib/Dialect/Linalg/Transforms/Promotion.cpp:116
+    fullRanges.push_back(size);
+    partialRanges.push_back(folded_std_dim(folder, subView, rank));
   }
----------------
Nit: This isn't ranges any more? please rename it.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D77676/new/

https://reviews.llvm.org/D77676





More information about the llvm-commits mailing list