[PATCH] D76742: [lld] Add basic symbol table output

Jez Ng via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 26 22:48:36 PDT 2020


int3 added inline comments.


================
Comment at: lld/MachO/Writer.cpp:396
+  for (Symbol *sym : symtab->getSymbols()) {
+    uint8_t n_type = N_UNDF;
+    uint8_t n_sect = NO_SECT;
----------------
smeenai wrote:
> Nit: variable naming
I wonder if we should just drop the `n_` prefix for internal variable names, i.e. just `strx` instead of `nStrx`. Not really sure why `n_` was added in the first place, but it seems like some kind of ad-hoc namespace convention? (Not that it really makes sense for struct members...) In any case it doesn't seem to add much to code readability


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D76742/new/

https://reviews.llvm.org/D76742





More information about the llvm-commits mailing list