[PATCH] D73086: [WIP][DWARF5] Added support for debug_macro section parsing and dumping in llvm-dwarfdump.

Sourabh Singh Tomar via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Mar 13 05:06:54 PDT 2020


SouraVX marked 2 inline comments as done.
SouraVX added inline comments.


================
Comment at: llvm/test/DebugInfo/X86/debug-macro-macinfo.s:52-55
+	.ascii	"DWARF_VERSION"
+	.byte	32
+	.byte	52
+	.byte	0
----------------
ikudrin wrote:
> You may just use `.asciz "DWARF_VERSION 4"` instead. It is the same but more readable.
Removing this since `macinfo` represent info in section itself not in `debug_str` so this is also un-necessary! Sorry for the confusion caused here.
+ Removing other- duplicate/un-necessary string after scrutinizing. 


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D73086/new/

https://reviews.llvm.org/D73086





More information about the llvm-commits mailing list