[PATCH] D74471: [AArch64][SVE] Add predicate reinterpret intrinsics

Sander de Smalen via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Feb 12 06:13:10 PST 2020


sdesmalen accepted this revision.
sdesmalen added a comment.
This revision is now accepted and ready to land.

Simple patch that implements the conversions to/from svbool_t, looks good to me!



================
Comment at: llvm/test/CodeGen/AArch64/sve-intrinsics-reinterpret.ll:43
+
+define <vscale x 16 x i1> @reinterpret_bool_b2b_from() {
+; CHECK-LABEL: reinterpret_bool_b2b_from:
----------------
nit: the naming is a bit inconsistent here, maybe rename the tests to have either: `_from_b`, `_from_h`, `_from_s`, `_from_d` and `_to_b`, `_to_h`, `_to_s`, `_to_d`  instead of the `b2b`, `b2h`, `h2b`, etc.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D74471/new/

https://reviews.llvm.org/D74471





More information about the llvm-commits mailing list