[PATCH] D71473: [Alignment][NFC] Deprecate untyped variants of CreateMemCpy/CreateMemMove

Dávid Bolvanský via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Dec 16 06:52:32 PST 2019


xbolva00 added inline comments.


================
Comment at: llvm/lib/Transforms/Utils/SimplifyLibCalls.cpp:565
   CallInst *NewCI =
-      B.CreateMemCpy(Dst, 1, Src, 1,
+      B.CreateMemCpy(Dst, Align::None(), Src, Align::None(),
                      ConstantInt::get(DL.getIntPtrType(CI->getContext()), Len));
----------------
I am wondering if the new code does not hurt a readability... Here we have a comment, but.. Looking at Align::None(), I had to open doc for Alignment.h to see how it is defined.

In my opinion, 'Align(1)' looks better.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D71473/new/

https://reviews.llvm.org/D71473





More information about the llvm-commits mailing list