[PATCH] D68639: [MachineScheduler] Add a flag to enable scheduling of cfi instructions

Florian Hahn via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 8 07:38:59 PDT 2019


fhahn added a comment.

In D68639#1699596 <https://reviews.llvm.org/D68639#1699596>, @tellenbach wrote:

> In D68639#1699548 <https://reviews.llvm.org/D68639#1699548>, @fhahn wrote:
>
> > I've not looked to closely yet, but isn't that basically the same we do for debug values? If that's the case, I think we should consider unifying the code to handle debug & CFI. Specifically, would it be possible to just extend the current handling of debug instructions to also handle CFI instructions? That should some renaming and a few code changes. I think.
>
>
> You are absolutely correct, this is essentially the same as for debug values with the addition that it can be disabled. I will try to unify both approaches, maybe both loops (currently one for the vector of debug values and one for the vector of cfi instructions) can be fused into one.


I think we could just use the same map for both debug and CFI instructions and then just rename placeDebugInstruction to something like placeUnscheduledInstructions.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D68639/new/

https://reviews.llvm.org/D68639





More information about the llvm-commits mailing list