[PATCH] D67987: [sanitizer_common] Rename OnPrint to __sanitizer_on_print.

Matt Morehouse via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 1 13:12:25 PDT 2019


morehouse added a comment.

In D67987#1684026 <https://reviews.llvm.org/D67987#1684026>, @dvyukov wrote:

> For the Go version we have a non-weak  declaration without definition. How are we going to roll out the change? We would need to update llvm and the hook implementation atomically. But then I am confused how it works today. We have a non-extern "C" hook definition, so build should be broken for the last year...


I'm also not sure exactly why it's working internally.  Apparently the `extern "C"` doesn't matter when compiling the race detector stuff, but I do get a linking error if I change the symbol name.

Let's temporarily keep the `OnPrint` symbol for Go.  This will give us time to migrate to `__sanitizer_on_print` internally and then remove `OnPrint` here.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D67987/new/

https://reviews.llvm.org/D67987





More information about the llvm-commits mailing list