[PATCH] D68095: Add a unittest to verify for assumption cache

Vedant Kumar via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 30 13:09:35 PDT 2019


vsk added inline comments.


================
Comment at: llvm/unittests/Transforms/Utils/CodeExtractorTest.cpp:233
+  std::unique_ptr<Module> M(parseAssemblyString(
+        "target datalayout = \"e-m:e-i8:8:32-i16:16:32-i64:64-i128:128-n32:64-S128\" "
+        "target triple = \"aarch64\" "
----------------
The extended string literal syntax would aid readability here, e.g.
```
const char* s1 = R"ir(
Hello
World
)ir";
```


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D68095/new/

https://reviews.llvm.org/D68095





More information about the llvm-commits mailing list