[PATCH] D68200: [AMDGPU] Extend buffer intrinsics with swizzling

Nicolai Hähnle via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 30 10:03:58 PDT 2019


nhaehnle added inline comments.


================
Comment at: lib/Target/AMDGPU/SILoadStoreOptimizer.cpp:522
 
+  /* Do not merge VMEM buffer instructions with "swizzled" bit set. */
+  int swizzled = AMDGPU::getNamedOperandIdx(CI.I->getOpcode(), AMDGPU::OpName::swz);
----------------
piotr wrote:
> arsenm wrote:
> > Single line comment
> Ah yes, sorry I keep making this error. I will use the C++-style comment and also rename "swizzled" to "Swizzled".
In the discussion in August there seems to have largely been consensus for moving LLVM towards lowerCamelCase variable naming.


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D68200/new/

https://reviews.llvm.org/D68200





More information about the llvm-commits mailing list