[PATCH] D67287: [Diagnostics] Add -Wsizeof-array-div

Dávid Bolvanský via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Sep 12 02:44:33 PDT 2019


xbolva00 added a comment.

Thanks, ugh, that’s weird. Yes, very questionable code. I would probably change it to

unsigned blockSize = sizeof(uint64_t);
sizeof(cdata) / blockSize;

and add a code comment that interface requires such blocks. Warning will go away and code readability will be better.


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D67287/new/

https://reviews.llvm.org/D67287





More information about the llvm-commits mailing list