[PATCH] D65716: [ELF] Consistently prioritize non-* wildcards overs "*" in version scripts

Fangrui Song via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Aug 5 06:40:00 PDT 2019


MaskRay marked 2 inline comments as done.
MaskRay added inline comments.


================
Comment at: ELF/Config.h:310
 
+static inline ArrayRef<VersionDefinition> versionDefinitionsNotLocalOrGlobal() {
+  return llvm::makeArrayRef(config->versionDefinitions).slice(2);
----------------
ruiu wrote:
> grimar wrote:
> > `versionDefinitionsNotLocalOrGlobal` looks a bit too long name.
> > May be `namedVersionDefs` or something else would be better?
> I feel the same. How about `getUserDefinedVersions`? Also I feel that this function needs a comment, as the magic number 2 is not obvious.
I went with `namedVersionDefs`, because global and local are sometimes referred to as `anonymous`, so `named` seems a good name. Will happy to change if there is a better name.


Repository:
  rLLD LLVM Linker

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D65716/new/

https://reviews.llvm.org/D65716





More information about the llvm-commits mailing list