[PATCH] D65716: [ELF] Consistently priority non-* wildcards overs "*" in version scripts

Rui Ueyama via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Aug 5 06:04:58 PDT 2019


ruiu added inline comments.


================
Comment at: ELF/Config.h:310
 
+static inline ArrayRef<VersionDefinition> versionDefinitionsNotLocalOrGlobal() {
+  return llvm::makeArrayRef(config->versionDefinitions).slice(2);
----------------
grimar wrote:
> `versionDefinitionsNotLocalOrGlobal` looks a bit too long name.
> May be `namedVersionDefs` or something else would be better?
I feel the same. How about `getUserDefinedVersions`? Also I feel that this function needs a comment, as the magic number 2 is not obvious.


Repository:
  rLLD LLVM Linker

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D65716/new/

https://reviews.llvm.org/D65716





More information about the llvm-commits mailing list