[PATCH] D64827: [Xtensa 2/10] Add Xtensa ELF definitions.

Andrei Safronov via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jul 17 15:12:37 PDT 2019


andreisfr marked 2 inline comments as done.
andreisfr added inline comments.


================
Comment at: llvm/include/llvm/BinaryFormat/ELF.h:775
+  /* Various CPU types.  */
+  E_XTENSA_MACH = 0x00000000,
+  EF_XTENSA_XT_INSN = 0x00000100,
----------------
appcs wrote:
> Typo? (Just making sure it isn't).
I took as a basis naming conventions of the e_flags from binutils (binutils/include/elf/xtensa.h). There used similar names for the architecture mask and  base machine architecture with only differenece in prefix (E_ or EF_).


================
Comment at: llvm/include/llvm/BinaryFormat/ELFRelocs/Xtensa.def:11
+ELF_RELOC (R_XTENSA_RELATIVE, 5)
+ELF_RELOC (R_XTENSA_PLT, 6)
+ELF_RELOC (R_XTENSA_OP0, 8)
----------------
appcs wrote:
> Just making sure a '7' RELOC is not missing.
It is missing also in binutils (binutils/include/elf/xtensa.h). So I left it as is.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D64827/new/

https://reviews.llvm.org/D64827





More information about the llvm-commits mailing list