[PATCH] D64570: [scudo][standalone] NFC corrections

Kostya Kortchinsky via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jul 11 09:16:52 PDT 2019


cryptoad created this revision.
cryptoad added reviewers: hctim, morehouse, eugenis, vitalybuka.
Herald added subscribers: Sanitizers, delcypher.
Herald added projects: LLVM, Sanitizers.

A few corrections:

- rename `TransferBatch::MaxCached` to `getMaxCached` to conform with the style guide;
- move `getBlockBegin` from `Chunk::` to `Allocator::`: I believe it was a fallacy to have this be a `Chunk` method, as chunks' relationship to backend blocks are up to the frontend allocator. It makes more sense now, particularly with regard to the offset. Update the associated chunk test as the method isn't available there anymore;
- add a forgotten `\n` to a log string;
- for `releaseToOs`, instead of starting at `1`, start at `0` and `continue` on `BatchClassId`: in the end it's identical but doesn't assume a particular class id for batches;
- change a `CHECK` to a `reportOutOfMemory`: it's a clearer message


Repository:
  rCRT Compiler Runtime

https://reviews.llvm.org/D64570

Files:
  lib/scudo/standalone/chunk.h
  lib/scudo/standalone/combined.h
  lib/scudo/standalone/local_cache.h
  lib/scudo/standalone/primary32.h
  lib/scudo/standalone/primary64.h
  lib/scudo/standalone/report.cc
  lib/scudo/standalone/tests/chunk_test.cc

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D64570.209246.patch
Type: text/x-patch
Size: 7253 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20190711/d38673cf/attachment.bin>


More information about the llvm-commits mailing list