[PATCH] D62819: [SCCP] Add UnaryOperator visitor to SCCP

Cameron McInally via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jun 3 12:55:18 PDT 2019


cameron.mcinally marked an inline comment as done.
cameron.mcinally added inline comments.


================
Comment at: llvm/lib/Transforms/Scalar/SCCP.cpp:975
+void SCCPSolver::visitUnaryOperator(Instruction &I) {
+  LatticeVal VState = getValueState(I.getOperand(0));
+
----------------
fhahn wrote:
> nit: I think Op0V or something that makes it explicit that this ties back to the first operand of the instruction would be a slightly better name.
Oh, just realized you requested `Op0V` instead of `V0State`. I copied that naming from visitBinaryOperator(...). Are you okay with this?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D62819/new/

https://reviews.llvm.org/D62819





More information about the llvm-commits mailing list