[PATCH] D62210: [WebAssembly] Implement __builtin_return_address for emscripten

Sam Clegg via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue May 21 15:02:37 PDT 2019


sbc100 added inline comments.


================
Comment at: llvm/lib/Target/WebAssembly/WebAssemblyISelLowering.cpp:277
+  // Define the emscripten name for return address helper.
+  setLibcallName(RTLIB::RETURN_ADDRESS, "emscripten_return_address");
+
----------------
I kind of agree with Dan re: the naming of this.

If anything we should we at least put "__" at the start so that its clear this is not a normal user function.

What is this called on other plaforms?  Why not just call it "__builtin_return_address"?


================
Comment at: llvm/lib/Target/WebAssembly/WebAssemblyISelLowering.cpp:992
+    return SDValue();
+  }
+
----------------
Should we just lower this anyway?  And thereby turn this from compile error into a link error if you happen to have not implemented it?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D62210/new/

https://reviews.llvm.org/D62210





More information about the llvm-commits mailing list