[PATCH] D60042: [llvm-objcopy] Add --prefix-alloc-sections

James Henderson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu May 2 01:41:19 PDT 2019


jhenderson added inline comments.


================
Comment at: llvm/tools/llvm-objcopy/ELF/ELFObjcopy.cpp:599
+      if (!Config.AllocSectionsPrefix.empty()) {
+        if ((Sec.Flags & SHF_ALLOC) != 0) {
+          Sec.Name = (Config.AllocSectionsPrefix + Sec.Name).str();
----------------
MaskRay wrote:
> It looks most other places don't put ` != 0`
Hmm... I find `!= 0` easier to read personally, but I don't feel strongly about it.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D60042/new/

https://reviews.llvm.org/D60042





More information about the llvm-commits mailing list