[PATCH] D60367: [TableGen] Introduce !listsplat 'binary' operator

Roman Lebedev via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sat Apr 6 23:38:09 PDT 2019


lebedev.ri added a comment.

In D60367#1457471 <https://reviews.llvm.org/D60367#1457471>, @craig.topper wrote:

> I wonder if !listfill might be a better name? I feel like splat has a meaning to those of us who have worked on vectors within LLVM IR, but may not be meaningful right away to other people?


Normally `std::fill()` sets all the specified elements to the specified value.
To me, this isn't the case here, while we do fill the list, we don't 'fill the list', since we don't get any list..
That is at least how i see this. I totall can change it if other reviewers also agree that it would be better.


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D60367/new/

https://reviews.llvm.org/D60367





More information about the llvm-commits mailing list