[polly] r357107 - [ConstantRange] Rename isWrappedSet() to isUpperWrapped()

Nikita Popov via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 27 11:19:33 PDT 2019


Author: nikic
Date: Wed Mar 27 11:19:33 2019
New Revision: 357107

URL: http://llvm.org/viewvc/llvm-project?rev=357107&view=rev
Log:
[ConstantRange] Rename isWrappedSet() to isUpperWrapped()

Split out from D59749. The current implementation of isWrappedSet()
doesn't do what it says on the tin, and treats ranges like
[X, Max] as wrapping, because they are represented as [X, 0) when
using half-inclusive ranges. This also makes it inconsistent with
the semantics of isSignWrappedSet().

This patch renames isWrappedSet() to isUpperWrapped(), in preparation
for the introduction of a new isWrappedSet() method with corrected
behavior.

Modified:
    polly/trunk/lib/Analysis/ScopInfo.cpp

Modified: polly/trunk/lib/Analysis/ScopInfo.cpp
URL: http://llvm.org/viewvc/llvm-project/polly/trunk/lib/Analysis/ScopInfo.cpp?rev=357107&r1=357106&r2=357107&view=diff
==============================================================================
--- polly/trunk/lib/Analysis/ScopInfo.cpp (original)
+++ polly/trunk/lib/Analysis/ScopInfo.cpp Wed Mar 27 11:19:33 2019
@@ -843,7 +843,7 @@ void MemoryAccess::computeBoundsOnAccess
   if (Range.isFullSet())
     return;
 
-  if (Range.isWrappedSet() || Range.isSignWrappedSet())
+  if (Range.isUpperWrapped() || Range.isSignWrappedSet())
     return;
 
   bool isWrapping = Range.isSignWrappedSet();




More information about the llvm-commits mailing list