[PATCH] D59320: [HWASan] Use less Printf() calls in register dump.

Peter Collingbourne via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 13 16:54:31 PDT 2019


pcc added inline comments.


================
Comment at: compiler-rt/lib/hwasan/hwasan_report.cpp:468
+         "  x%d %016llx\n",
+         28, frame[28], 29, frame[29], 30, frame[30]);
 }
----------------
I reckon that it may make the code easier to read if we just wrote out all the printf calls, i.e.
```
    Printf("    x0  %016llx  x1  %016llx  x2  %016llx  x3  %016llx\n",
           frame[0], frame[1], frame[2], frame[3]);
```
and so on. What do you think?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D59320/new/

https://reviews.llvm.org/D59320





More information about the llvm-commits mailing list