[PATCH] D59160: lit: Remove the binary_feature function and inline it everywhere.

Zachary Turner via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Mar 8 15:01:05 PST 2019


zturner added a comment.

For some context, the reason I added this in the first place is because there used to be a lot of inconsistency in the feature names, so I was trying to give consistency.  For example, we would have `not-<feature>` in some places and `<not>_feature` in other places.  You can even see an example of this here, where it's `zlib` and `nozlib` instead of `zlib` and `not_zlib`.  This inconsistency makes it hard for people to guess the correct negation for the feature they're trying to specify.

Or, someone would define the feature but not the converse of it, so we'd get `x` but there would be no corresponding feature for `not_x`.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D59160/new/

https://reviews.llvm.org/D59160





More information about the llvm-commits mailing list