[PATCH] D57324: lld/coff: Implement some support for the comdat selection field

Nico Weber via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jan 28 06:18:26 PST 2019


thakis marked an inline comment as done.
thakis added inline comments.


================
Comment at: lld/COFF/InputFiles.cpp:447
+  // Handle comdat leader.
   if (const coff_aux_section_definition *Def = ComdatDefs[SectionNumber]) {
     ComdatDefs[SectionNumber] = nullptr;
----------------
This function is getting fairly long; probably want to move the whole contents of this if to its own function or something. But I thought I'd see if you have other comments first since moving the contents is easy to do.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57324/new/

https://reviews.llvm.org/D57324





More information about the llvm-commits mailing list