[PATCH] D57128: Add --unwindlib=[libgcc|compiler-rt] to parallel --rtlib=

Richard Smith - zygoloid via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jan 24 19:30:32 PST 2019


rsmith accepted this revision.
rsmith added a comment.
This revision is now accepted and ready to land.

Looks good to me, thanks! Let's try this and see if it shakes out any problems.

We really need to give LLVM's unwinder a better name.



================
Comment at: clang/include/clang/Driver/Options.td:2572
+def unwindlib_EQ : Joined<["-", "--"], "unwindlib=">, Flags<[CC1Option]>,
+  HelpText<"Unwind library to use">, Values<"libgcc_eh,compiler-rt-unwind,platform">;
 def sub__library : JoinedOrSeparate<["-"], "sub_library">;
----------------
I think `libgcc_eh` here should be just `libgcc`, and `compiler-rt-unwind` should be just `compiler-rt`, right?


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57128/new/

https://reviews.llvm.org/D57128





More information about the llvm-commits mailing list