[PATCH] D56845: [AMDGPU] Add some missing always-uniform values.

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jan 17 14:40:55 PST 2019


arsenm accepted this revision.
arsenm added a comment.
This revision is now accepted and ready to land.

LGTM with name fix



================
Comment at: test/Analysis/DivergenceAnalysis/AMDGPU/always_uniform.ll:3-4
 
-define amdgpu_kernel void @workitem_id_x() #1 {
+; CHECK: for function 'workitem_id_x':
+define amdgpu_kernel void @workitem_id_x() {
   %id.x = call i32 @llvm.amdgcn.workitem.id.x()
----------------
arsenm wrote:
> This should probably be renamed, it's really testing readfirstlane, not work item.id.x
You changed this but didn't change the name?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D56845/new/

https://reviews.llvm.org/D56845





More information about the llvm-commits mailing list