[PATCH] D55638: [CallSite removal] Add and flesh out APIs on the new `CallBase` base class that previously were only available on the `CallSite` wrapper.

Chandler Carruth via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 27 15:27:57 PST 2018


chandlerc added a comment.

Added FIXMEs for future renaming and corrected the other comment mentioned.



================
Comment at: llvm/include/llvm/IR/InstrTypes.h:1393
+  /// Determine whether this argument is passed by value.
+  bool isByValArgument(unsigned ArgNo) const {
+    return paramHasAttr(ArgNo, Attribute::ByVal);
----------------
compnerd wrote:
> Can we name this `isKnownByValArgument`?
Here I don't think we should rename -- `byval` is a fundamental property of whether an attribute was placed there or not. If the attribute is missing, it will not get those semantics. So I think the wording of this is actually fine.


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D55638/new/

https://reviews.llvm.org/D55638





More information about the llvm-commits mailing list