[PATCH] D51207: Introduce llvm.experimental.widenable_condition intrinsic

Philip Reames via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Dec 4 20:53:54 PST 2018


reames accepted this revision.
reames added a comment.
This revision is now accepted and ready to land.

LGTM w/minor comment to be addressed before landing.

Note: I am specific LGTMing this in the current form, despite the previously raised question about naming.  Given the conversation appears to have died and this is in the experimental namespace allowing naming changes anyway, it's time to land this patch and then iterate in tree if needed.  If anyone *actively objects* feel free to speak up, but let's not let bikeshedding block progress here if we can avoid it.



================
Comment at: include/llvm/IR/Intrinsics.td:833
 
+// Supports widenable conditions for explicitly expressed guards.
+def int_experimental_widenable_condition : Intrinsic<[llvm_i1_ty], [],
----------------
fedor.sergeev wrote:
> for guards represented as explicit branches
please remove the "for guards represented ..." part.  The intrinsic is specified in a more generic manner than just for guards.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D51207/new/

https://reviews.llvm.org/D51207





More information about the llvm-commits mailing list