[PATCH] D54200: [PPC64] Use -0x80000000LL instead of std::numeric_limits<int32_t>::min()

James Henderson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Nov 7 05:53:33 PST 2018


jhenderson added a comment.

In https://reviews.llvm.org/D54200#1290042, @ruiu wrote:

> My preference is INT32_MIN which works both in C and C++, but I don't think 0x80000000 is more readable than `numeric_limits<int32_t>::min()`. Honestly it looks a bit more like an exercise to see if you really understand how negative numbers are represented in the two's complement, I think.


I have no objection to INT32_MIN, as it's clear as to the purpose.


Repository:
  rLLD LLVM Linker

https://reviews.llvm.org/D54200





More information about the llvm-commits mailing list